
Editing with Adobe Premiere Pro
Instructor: John Aden

Class Objectives

● Learn good file management skills
● Learn the basics of editing with Adobe Premiere Pro
● Learn to edit a short video using a-roll, b-roll, music, and still images

Again, the primary focus of this curriculum is to ensure that you assemble your projects 
correctly and that you understand where all your files are saved so that you never lose your 
work.  The more advanced and aesthetic aspects of editing are best to learn on your own or in 
our advanced editing class.

If you follow these instructions while working in class or on your own, you will never 
lose your work, and your project and files will be organized in a way that makes sense.  Please 
follow them closely, even if you think you already know how to capture and organize your 
projects.

Getting Started

Basic Components of Workstations
● Keyboard
● Right-clicking
● Volume
● Headsets

 
File Management

● Create a new file on the desktop that is titled Adobe Premiere Pro Workshop
● Inside this folder, create two more folders

○ Media Files - the folder that will hold the “ingredients” for your program - video 
files, clips you capture from your DV tapes, photos, music, etc.

○ Project Files - the folder that will hold your project file, which is the “recipe” of 
your program and show how the “ingredients” are used
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Opening Adobe Premiere Pro

Click on this icon, located in your computer’s dock

(When you first open Adobe Premiere Pro, you may be prompted to reset your scratch 
disks.  If so, please refer “Setting your Scratch Disks” below.)

Creating a New Project

● Upon opening, Adobe Premiere Pro will automatically open a new window.

● Select New Project.

● Premiere will open a new window:
○ If you are going to be working with Standard Definition footage, click on the 

Capture Format drop-down menu and choose DV
○ If you’re working in High Definition, select HDV.

● In the Location area, click Browse, navigate to the Project Files folder inside the folder 
you created on the desktop, and select Choose.  This will save the Adobe Premiere 
project file here. Enter a project file title under Name.  For the purposes of this class, 
save your project as the last names of the individuals working on the project.

Setting the Scratch Disks:
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● Navigate to the Scratch Disks tab.
○ Scratch disks allow you to set permanent destinations for subsidiary files created 

while you are working in Adobe Premiere Pro that will help your project stay 
organized.

● Select the Browse button under the Capture Video section, navigate to the Media Files 
folder inside the folder you created on the desktop, and select Choose.

● Set the same destination for the scratch disks under Captured Audio, Video Previews 
and Audio Previews.

● Continue by clicking OK.

New Sequence Settings

Premiere will direct you to this window.  This window will allow you to set settings for the 
sequence you will be editing momentarily. It features several presets that will easily customize 
the sequence to match common types of video footage.

If you are absolutely sure of the format that you are working in, you can select it here.  
Otherwise, click Cancel.  You will be able to create a sequence directly from your captured or 
imported footage at a later point. Otherwise, name your sequence under Sequence Name click 
OK to continue.
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Saving Project Files

You should then immediately ensure that your project is saved in the Project Files folder that 
you created on your desktop (File > Save As…).

Resetting the Premiere Pro Workspace

You can reset the workspace to its default appearance by clicking on Window > 
Workspace> Reset Current Workspace.

Understanding the Adobe Premiere Pro Workspace

There are 4 main windows in Adobe Premiere Pro.  

Project (bottom left): This window holds a list of your master media clips, sequences and bins 
(folders for your media).  This window also holds the Media Browser.  Click the tab next to 
Project to open the Media Browser.  You can browse the computer for media. You can drag and 
drop files from here to the project window to import them.

Source (upper left):  Window used for viewing clips and also for adjusting filters and other 
aspects of these clips.  This is the window that displays information specific to the clip that you 
have selected.

Timeline (lower center):
The Timeline shows your audio and video clips in a linear sequence and lets you edit and 
arrange them.  This is where the majority of your editing should take place.  While some 
trimming can be done in the Source, we encourage you to get used to trimming and editing 
within the Timeline.

Program (upper right):  The program window is used for viewing the results of the work you 
have done on the Timeline.  This will be the final output of your video, including all effects, 
transitions, text, and so on.

To view the Title Safe and Action Safe frames of your video, select click Safe Margins 
in the drop-down menu in the upper righthand corner of either the Source or Program windows. 
The outlined boxes represent Title Safe and Action Safe.  Some TVs will crop out the portion of 
your image that falls outside these boxes, so you will want to make sure all of the images that 
you care about reside within these guidelines.

In the workspace, you will also see these items.
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Audio Master Meters (bottom right): Allows you to track audio levels and peaks as you play 
through your source footage or your edited sequences.

Tools (bottom center):  This is the narrow window that holds the tools that you can use to 
accomplish various tasks.  In this class, we will only be covering the Selection Tool (V - used 
for moving clips on the Timeline), the Razor Tool (C - used for cutting clips), and the Ripple 
Edit Tool (B - used for trimming clips).  These tools are the most useful when beginning to edit, 
with the others becoming more useful as you get more comfortable with the program.

Creating Bins

It is wise to keep your Project window well organized in a way that lets you find specific 
clips quickly and easily.  Create a bin by holding down the “control” key and clicking the mouse 
in the Project window and selecting New Bin, or by clicking the New Bin icon at the bottom of 
the Project window.  You can also use the keyboard shortcut Command /.  Make as many bins 
as you need to organize your project and name them appropriately (ARoll, BRoll, Logos, Music, 
etc).

Importing Media

For this class, we will import media from the Editing Class Assets on your desktop.  To 
import these files into Adobe Premiere Pro, go to the top menu screen in Adobe Premiere Pro 
and select File>Import or Command I.  Use the pop-up window to find the file you wish to 
import and then click Import.  The imported media will appear as clips in your Project window.

You can also import files by selecting them in the Media Browser and dragging them to 
the Project window.

Viewing a Clip

Double-click on a clip in the Project window, and it will appear in the Source window.  
Here you can trim it with the I (Mark In) and O (Mark Out) keys before bringing it into your 
Timeline.

While working in the Source you will notice that there are the Effect Controls tab, which 
allow you to manipulate both video and audio of the clip being viewed in the Source window.

Video and Audio Tracks
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Once you start laying clips in your Timeline, you will notice a couple of different tracks.  
Your video tracks are displayed on top of the Timeline.  Underneath these are audio tracks, 
displayed on the bottom.

Playhead

This is the red vertical line that is topped with a blue marker on the Timeline and cuts 
down through all of the tracks. This shows you which frame you are looking at on the program, 
and is key to navigating through the Timeline.  (Please note: When navigating through the 
Timeline, click your mouse in the Timeline in the space that contains the timecode.  This will 
allow you to easily place the playhead where you want to.)

Creating a New Sequence Based on Footage Settings:

If you already created your sequence using a preset at the beginning of the class, skip 
this step.  If not, continue on here.

To create a sequence with settings that match your imported footage, drag one of your 
video clips (one that is representative of the type of how most of your video is shot) to the New 
Item icon in the bottom righthand corner of the Project window.  This will create a new sequence 
containing that clip, but more importantly, with settings that correctly match your footage.  
Rename the sequence as you choose.  This step also adds the clip to the Timeline, in case you 
want to delete it from there.

Editing

Well-edited projects are trimmed to get their message across as clearly and concisely as 
possible.  They also contain a good amount of b-roll (cutaway footage) when appropriate and 
only use solid speaking points.  So, our goal in this class will be to take a few interview clips, 
trim them down to the most essential, concise portions possible, and then cover the visuals with 
some interesting b-roll to illustrate the topic being discussed.  We will then add logos, titles, and 
music.

Three-Point Editing

1. Start (or In) point on clip to be added
2. End (or Out) point on clip to be added
3. Start point on Timeline (where in the Timeline you want your clip to be added, usually 

determined by where you drag the clip)
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Managing your clips on the Timeline:

To bring a clip onto the Timeline, drag it from Source window into the Timeline and drop 
it into the spot where you want it.  Notice that you can place the clip on top of or next to another 
clip in the Timeline, as well as place the clip into different tracks.

Stacked Clips

● Video - If video clips are stacked on top of one another, only the top clip will be visible
● Audio - Stacked audio tracks will all play simultaneously when the playhead runs over 

them

Navigating Clips in the Timeline or Source Viewer

● Place the playhead at the beginning of the section you want to watch and press the 
spacebar.  Press the spacebar again to stop.

● To control the motion of the playhead, you can use the keyboard keys J (play forward), 
K (stop), and L (play backwards).

● Press J or L more than once to increase the speed of forward/reverse playback.
● To advance the playhead one frame, press the forward arrow once.
● To move the playhead back one frame, press the back arrow once.
● To go to the beginning of the sequence or clip, press the home key.
● To go to the end of the sequence or clip, press the end key.

Razor Tool

● Park the playhead where you want to make the cut.
● Bring your mouse to the Tools menu and click on the Razor Tool (icon looks like a 

razor) or press C.
● Bring your mouse (which should now be shaped like the razor) back to the point on the 

clip where your playhead is and click.
● A seam (or edit) will appear where the cursor playhead is parked.
● After making all additional cuts, you must switch back to the Selection Tool (either by 

clicking in the tool palette or by typing V) to select the portions or the clip that you wish to 
delete.

Trimming in the Timeline
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With the Selection Tool (V) selected, place the mouse on the furthest edge of the clip 
until the mouse arrow becomes a red bracket with small arrows pointing left and right. When this 
happens, click on your mouse and drag the edge of the clip to the desired point 

Snapping

This button is in the top lefthand corner of the Timeline or you can simply tap the S key.  When 
enabled, the playhead will “snap” to the closest edit point while you are trimming a clip.

Video Transitions

● Go to the Effects tab in the Project window
● Drop down the Video Transitions menu
● The disclosure triangle will twirl down showing a list of the various transition types that 

you can choose from; each of these options also has a submenu of more options you 
can choose from

● Select a transition
● Drag it over and then drop it in between the two clips you would like to apply the 

transition to
● The transition will appear on the Timeline as a purple stripe across the top of the edit 

seam.

Audio Levels

The easiest way to adjust audio levels is to drag the yellow line that crosses the audio on 
every track.  Dragging it upwards will make the media play louder, dragging it down will soften it.  
Aim to have your audio to ride between -12 and -6 dBs.

Effects

● To add an effect to a particular clip, go to the Effects tab in the Project window
● Drop down Video Effects
● Each of these options will also have a submenu of more options you can try
● Select the effect you would like to try
● Drag it on top of the clip you want to apply it to in the Timeline

Once you have the effect applied to the right clip and rendered, right-click or control-click 
on the clip and select Copy.  You can now paste this filter to other clips, by selecting the other 
clips, right-clicking or control-clicking on the group of clips and selecting Paste Attributes.  This 
will apply all modifications, including added effects, to the other selected clips.
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Titles and Text

● Go to File > New > Title or hit Command T.  A new window will open that will allow you 
to set the size and name your title.  Click OK.

● A window will appear with several title design options.  Click in the window showing 
the video to start typing.  You can change the text and adjust size, font, style and color 
under the title properties.  You can select a title style under the title style tab.

● Under the title window tab, click on this button to select still, scroll or roll.
● Once you have entered the text, close the title window and drag the clip from the project 

to the Timeline. Place the text clip on a track directly above another clip and it will be 
transposed on the clip.

● If you wish to have a specific colored background, place the text over an empty portion 
of the Timeline, or insert a Color Matte by going to File > New > Color Matte...  If you 
want a standard black background, you can select Black Video... from the same menu.

● Adjust the length of the text by dragging the ends in the Timeline.

Exporting Your Video for Denver Open Media

● Click File > Export > Media...
● Make sure the Source Range is set to Entire Sequence (or that you have properly 

selected the portion of your program that you want to export)
● Set Format to QuickTime
● Set Preset to HD 1080i 29.97, H.264, AAC 48kHz (if your program is in HD or high 

definition)
○ Bump quality up to 100%
○ Make sure data rate is set to 10,000 kbps

● Set Preset to NTSC, H.264, AAC 48kHz (if your program is in SD or standard definition)
● Click on Output Name to name your file and choose where to save it
● Make sure the Export Video and Export Audio boxes are checked
● Click the Export button

Exporting Your Video for Other Destinations

● Click File > Export > Media...
● Make sure the Source Range is set to Entire Sequence (or that you have properly 

selected the portion of your program that you want to export)
● Click on Output Name to name your file and choose where to save it
● Click the Queue button to open Adobe Media Encoder
● Select one of the System Presets (YouTube, Apple Devices, DVD, etc.) and drag it to 

the Queue on the left
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● Click on the green arrow to being the export

Extra Information

Creating DVD Chapters

If you want your DVD to have chapters, create chapter markers in the Adobe Premiere 
Pro sequence before exporting to DVD.

● In the sequence, make sure none of the clips are selected (if they are, click in a grey part 
of the Timeline to unselect)

● Move the playhead to the location where you want a chapter to begin
● Right-click or control-click in the timeline and choose Marker>Set Encore Chapter 

Marker; a dialogue box will appear
● You can name the marker; this name will appear in the DVD menu
● Click OK

Capturing Video Footage from Tape

● Connect your camera or deck
● Choose File>Capture
● Use stop, play, rewind, fast-forward buttons to search the footage
● Mark in and out points of where you want to start and end capturing of the footage that 

you want by using the bracket buttons (Set In point and Set Out point)
● In the Capture section of the window (bottom righthand corner), check Scene Detect; 

this will create a new file for every time there was a stop/start in recording on the tape
● Push the In/Out button to begin capturing

Version Control

If you want to keep different versions of your project (i.e., for different edit sessions that 
you work on your project), you can duplicate your sequence.  Right-click or control-click on the 
sequence name in the Project window and choose Duplicate.  You can name your sequences 
by date or sequentially, however you want to organize them.

Practice!
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