
Editing with iMovie
Instructor: John Aden

Class Objectives

● Learn the basic concepts of video editing
● Learn how to import video footage and photos for use in iMovie
● Learn how iMovie and iPhoto can work together
● Learn the basic operations of iMovie
● Learn how to share your movies

What is iMovie?

● Consumer-friendly video editing program by Apple
● Part of iLife - iMovie, iPhoto, and GarageBand
● Very similar to Final Cut Pro X (Apple’s professional editing system)

Basic Concepts of Editing

Video editing can be really fun, especially once you master a few basic features.  With 
a little bit of patience and experimentation, you will be producing smoothly edited videos in no 
time.

Here is an overview of the main concepts you need to know to edit video:

● From Camera to Computer (importing).  The first order of business is getting the 
video clips that you shot on your camera over to your computer for editing.  iMovie will 
work with most files that are .mov, .mp4 and .dv.  This includes video cameras that do 
or do not use tapes, digital still cameras, the camera on your computer, and iPhones 
and iPads.  Connect your device to your computer to begin the import process.  This is 
covered in detail below.

● Organization.  Sorting through all your video clips can be confusing, so it helps to 
organize them by marking your Favorites.

● Back it up.  Your video footage is special, you made it, so don't risk losing it.  Make 
backup copies on an external hard drive.  Should anything disastrous happen to your 
computer, you have the peace of mind knowing those memories and moments are 
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safely tucked away on your backups.

● General editing program layout.  Almost all editing programs follow the same basic 
structure, although they may use different names.

○ Events Library - where you keep all your video files and select the clips you want 
to use in your show

○ Project Library - a list of all of your programs or shows
○ Project Pane (Timeline) - where all the clips are assembled together to make 

your final show
○ Viewer - this is the small screen where you can view your clips or your show
○ Toolbar - allows the editor to switch between the tools used in the editing process

● Save frequently.  Fortunately, this is something you do not have to worry about with 
iMovie or Final Cut Pro X.  These programs automatically save as you go.  But be aware 
of this in case you are using another editing program that does not automatically save 
your progress.

● Editing and trimming.  Once you have your footage in the Event Library, you can select 
and drag clips onto the Project Pane to assemble your show.  Once your clip is on the 
Project Pane, you can fine tune your selections (edits).  We will be able to trim videos 
down so we use only the most important parts of each clip.  Don't be afraid to try things.  
The changes you make in your editing program will alter your raw footage, and you can 
always undo what you don’t like.

● Transitions and special effect.  Use transitions to dissolve between clips together, and 
add special effects to your video to add flare.  This can have a drastic effect on the feel 
of your video, so try out a few different types and see what helps to tell your story the 
best.  But be careful about going overboard!

● Text.  Adding text is handy for adding titles, captions, or credits to your video.

● Audio.  Sound and music can completely change the feel of your video.  You have basic 
controls for fading audio in and out, adjusting the overall volume, and once your audio is 
on the timeline, you can control where it will start and stop in your video.

● Exporting and sharing.  Once your project is complete, export  your show to share with 
the world, including on YouTube, Facebook, DVD,  and Denver Open Media.

● Other terms.
○ A-roll - primary footage used in a project, usually someone talking about the 

subject at hand
○ B-roll - cutaway footage used to add interest to the story and also to cover up 

edits
○ Raw footage - your video footage in its raw form, as captured by your camera
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Navigating and Customizing the iMovie Workspace

-Viewer

The iMovie viewer, which occupies the area in the upper-right corner of the iMovie 
window, is where you view your project or clips when you play or skim through them.

You can resize the viewer by doing either one of the following:
● Choose Window > Viewer > [size]
● Drag the light gray horizontal toolbar in the middle of the iMovie window up or 

down

-Event Library

The Event Library is a list of your events, which contains the video footage that you have 
imported.  You can show or hide the Event Library by pushing the star button on the lefthand 
corner of the Event Library/Browser window.

-Event Browser

The Event Browser displays the video clips in the Event that is selected in the Event 
Library.  It is where you view, skim and select select video to add to your projects.  The clips in 
the Event Browser are represented by filmstrip style icons proportional to the length of each edit 
that you have made.  You can change the length of the icons by moving the slider below the 
Event Browser.

-Project Library

The Project Library organizes and provides access to all your iMovie projects.  You 
can show or hide your Project Library by clicking on the Project Library arrow button on the top 
lefthand corner of the Project Pane.

-Project Pane

The Project Pane is your primary workspace for creating iMovie projects.  It is the 
timeline or sequence of how and in what order your clips will play.  You can drag video clips, 
audio, and other elements into the Project Pane to build your movies.  The edited sequence in 
the Project Pane is represented by filmstrip style icons proportional to the length of each edit 
that you have made.  You can change the length of the icons by moving the slider below the 
Project Pane.  You can also show or hide the audio waveforms of each clip by click on the icon 
next to the slider.
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You can switch the positions of the Event Browser and Project Pane by clicking on the double-
arrow button in the toolbar.  You can also get a more traditional Timeline view in the Project 
Pane by clicking on the button with the three boxes on the top of the Project Pane.

Creating a New Event

In iMovie, choose File > New Event.  Rename it, if you want.

Importing Video

● DV or HDV cameras (using tape)
○ Connect camera with Firewire cable
○ Set camera to VTR power mode
○ Choose Manual import, unless you want to import the entire tape (Automatic)
○ Select the footage you want to import
○ Options

■ Choose Save to: Macintosh HD (unless you are using an external hard 
drive)

■ Add to your existing Event: [Event name]
■ Check Optimize video: Full - Original Size

● Tapeless (memory-based) camera (record with flash memory, DVD, or hard drive) - USB
○ Connect camera with USB
○ Set camera to Playback or VTR power mode
○ Quit iPhoto or any other unnecessary applications that may open
○ Preview files
○ Check clips you want
○ Choose File > Import from Camera
○ Options

■ Choose Save to: Macintosh HD (unless you are using an external hard 
drive)

■ Add to your existing Event: [Event name]
■ Check Optimize video: Full - Original Size

● Digital cameras, smart phones (i.e., iPhones), and iPads
○ Import stills and video into iPhoto

● Importing files already on your computer
○ Choose File > Import > Movies
○ Options

■ Choose Save to: Macintosh HD (unless you are using an external hard 
drive)

■ Choose Add to existing Event: [Event name]
■ Check Optimize video: Full - Original Size
■ Choose Copy files
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Create a New Project

To work on a new video project in iMovie, you first create the project by giving it a name 
and defining other parameters for it.

iMovie comes with a selection of themes (Bulletin Board, Comic Book, Photo Album, 
etc.) that you can use in your movie.  Each theme comes with its own title styles and transitions 
that you can use to give your movie a polished and professional look.  When you select a 
theme, you can have iMovie automatically insert titles and transitions into your project as you 
add video clips to it.  You can always change or delete these elements later.

Start a new project by:

1. In iMovie, choose File > New Project.
2. To apply a theme to your project, select one of the themes presented below Project 

Themes. If you do not want to add any theme-based elements to your project, select No 
Theme. 

3. Type a name for the project in the Name field.
4. Choose a format option from the Aspect Ratio pop-up menu.  This format, which refers 

to the width and height dimensions of your movie, affects how the video appears on the 
screen.  Your selection should match the aspect ratio of the majority of your footage.

a. Widescreen (16:9): Makes the movie appear much wider than it is high. 
Widescreen movies are optimized for viewing on widescreen computer monitors 
and high-definition TVs (HDTVs).  When viewed on a standard-definition TV, 
widescreen movies appear with black areas above and below (sometimes 
referred to as “letterbox”). 

b. Standard (4:3): Makes the movie more square in shape. When viewed on a 
standard-definition TV, these movies can fill the screen. When viewed on an 
HDTV or widescreen computer monitor, they appear with black areas on the left 
and right of the video (sometimes referred to as “pillarbox”). 

5. Choose an option from the Frame Rate pop-up menu; choose the same frame rate that 
you used to shoot the video.

a. NTSC, PAL, and Cinema are video format standards that refer to the number 
of frames per second (fps) your recorded video contains.  In general, video 
cameras purchased in North America use the NTSC format (30 fps), and 
cameras purchased in Europe use the PAL format (25 fps).  Cinema format video 
has a frame rate of 24 fps.  If your camera was set to Cinema format when you 
shot your video, choose this option. 

6. If you did not select a theme in step 2 and you want iMovie to automatically include 
transition effects between video clips as you add them, select “Automatically add,” and 
then choose a transition style from the pop-up menu. 
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7. If you did select a theme for your project but do not want iMovie to add themed elements 
automatically, deselect “Automatically add transitions and titles.”

8. When this option is selected, iMovie automatically inserts cross-dissolve transitions and 
special themed transitions between clips, as well as a theme-styled introductory title over 
the first clip in your project, and a theme-styled credits title over the last clip. 

9. Click Create.

Go to iMovie > Preferences.  Make sure the Show Advance Tools option is checked 
under the General tab.

Add Video to Your Project

All of your imported video appears in the Event Library.  From there, you select specific 
video and add it to your project by dragging it to the project in the Project Pane, which is 
your project workspace.  As you add video and other elements to your project, they appear 
immediately in the Project Pane, where you can edit them, rearrange them, delete them, and so 
on.

1. In the Event Browser, select a clip or part of a clip that you want to use in your project.
a. To select an entire video clip, hold down the Shift key and click the clip once, so 

that it is outlined in yellow.
b. To select a portion of a clip (called a frame range), drag across any clip while you 

hold down the button on your mouse.  The selected frames are outlined in yellow.
2. Drag your video selection to the Project Pane.  You can drag it anywhere: to the 

beginning or end of the project or between clips you have already added.  A vertical 
green line, along with a green Add (+) symbol, appears anywhere you can place the clip.

Video that has been added to a project is marked along the bottom with an orange stripe 
in the Event Browser, so that you can see at a glance which video you have already used.  But 
you can always add the same video to multiple projects, and you can use it more than once 
within a project.

Continue adding video in this way until you have all the video you want in your project.  
Next, you can enhance your project by adding music, photos, titles, and more video.

Trimming Your Clips in the Project Pane

1. Click on the wheel in the bottom lefthand corner of the clip you want to trim
2. Clip on Clip Trimmer
3. Readjust your yellow selection bracket (longer or shorter) to get the desired effect)
4. Click done
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You can also make adjustments to adjacent clips by opening the Precision Editor.  
Select the Precision Editor by clicking on the wheel icon in one of those clips in the Timeline.

Add a Theme to Your Project

iMovie comes with a selection of themes you can use in your movie.  Each theme 
comes with its own title styles and transitions (visual effects that play between clips) that you 
can use to give your movie a big-budget look.  When you select a theme, you can have iMovie 
automatically insert titles and transitions into your project as you add video clips to it.  You can 
always change or delete these elements later.

If you did not choose a theme for your project when you first created it, you can apply 
one at any time thereafter.

1. Choose File > Project Theme.
2. Select a theme by clicking its thumbnail once; the theme previews automatically in the 

viewer on the right.
3. If you want to turn off automatic transitions and titles so that iMovie does not replace 

transitions that you have already added to your project, deselect “Automatically add 
transitions and titles.”

4. Click OK.

Add Music to Your Project

Background music you add to a project plays behind the audio recorded with your video, 
so that you can hear both tracks of sound at the same time.  You can adjust the volume of 
the background music so that it plays more loudly or softly, which allows you to layer sound in 
interesting ways.

The music in your iTunes library is automatically available for use in iMovie projects.  
iMovie and iLife also comes with sound effects and music.

1. Click the “Music and Sound Effect” button at the right end of the iMovie Toolbar.
2. The “Music and Sound Effect” Browser appears.
3. Choose one of the music options from the options at the top of the Music and Sound 

Effect Browser.
4. Drag the song to the Project Pane, to the dark gray area to the right of the last clip in 

your project, making sure that you do not drag it over a clip.
5. The background music well of your project is then shaded with green, representing the 

background music clip.
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a. The music begins at the start of your project and ends with your video, even if the 
song is longer than your video. 

b. If the music does not cover your entire video, you can add more music by 
dragging it to the background music well of your project.

6. To adjust the volume of the background music, click the Action pop-up menu (looks 
like a gear) in the upper lefthand corner of the green background music well, and then 
choose Audio Adjustments.

a. In the window that opens (called an Inspector), drag the volume slider, which 
appears at the top, to the right or left to increase or decrease volume, and then 
click Done. 

Add Photos to Your Project

You can add photos to your iMovie projects - to add visual interest, to highlight specific 
moments, or simply to break up the action of the video footage itself.  All of the photos in your 
iPhoto library are automatically available for use in iMovie.

1. Click the Photos button at the right end of the iMovie toolbar
2. Choose iPhoto from the pop-up menu at the top of the browser to see all the photos 

stored in iPhoto
3. Scroll through the thumbnails (miniatures) of the photos to find the one you want to add, 

and then click it so that it is outlined in blue
4. Drag your chosen photo to the project in the Project Pane

When you add a photo, by default it is set to remain onscreen in your project for 4 
seconds.  Also, the Ken Burns effect is applied to the photo.  This effect makes it appear as 
though the camera were panning across and zooming in on the image. 

1. To change how long the photo stays onscreen, double-click the photo in the Project 
Pane

2. In the window that opens (called an Inspector), type a new value, in seconds, in the 
Duration field, and then click Done

3. To change the Ken Burns effect, click on the photo in the Project Pane and then click 
on the wheel icon in the bottom lefthand corner of the photo and select Cropping, Ken 
Burns & Rotation

Add Titles

You can add onscreen text to any video in your project using one of the many title styles 
available in iMovie.  Onscreen text can be used to add a title and credits to your movie, to 
visually “narrate” the scenes in your movie, to create textual segues from one scene to the next 
(for example, “Ten years later” or “Later that same day”), and so on.
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1. Click the Title button at the right end of the iMovie toolbar
2. Browse the title styles, scrolling through the window if necessary, to find the one you 

want to use
3. Drag a title to the Project Pane directly over the clip where you want the title to appear

When you add a title, a blue or gold title bar appears above the video clip to show 
where the title appears in your video.  Blue title bars represent non-themed titles, and gold title 
bars represent themed titles.

Placeholder text (text that shows placement only and is meant to be replaced) appears 
in the Viewer on the right, and some or all of it is ready for editing (which means that it is 
selected and ready to be replaced by your own text). 

1. Replace the highlighted placeholder text by typing your own text
2. To play back the title (see how the title looks in your video), click the Play button in the 

upper righthand corner of the Viewer
3. Click Done in the upper righthand corner of the Viewer.

Add Transitions Between Clips

iMovie comes with several styles of transitions that you can add between clips to give 
professional polish to your projects.  A transition smoothes or blends the change from one 
scene to another.  For example, a transition can make one clip fade in or out, dissolve into 
another clip, zoom in to another clip, and so on.

iMovie makes all the transitions in your movie the same length.  Standard transitions are 
one-half of a second long, and theme-styled transitions (which are available only if you have set 
a theme for your project) are two seconds long.  You can change these durations if you want.

1. Click the Transition button at the right end of the iMovie toolbar.
2. Browse through the transition styles, scrolling the window if necessary, to find the one 

you want to use
3. Drag a transition to the Project Pane before, after, or between the clips where you want 

it to appear.
4. To play back the transition effect to see how the transition looks in your video, move 

your pointer in the Project Pane anyplace before the transition effect icon (you see a 
vertical red line where the pointer is), and then press the space bar

5. To change the duration of the transition, double-click the transition icon in the Project 
Pane

6. In the window that opens (called an Inspector), type a new value, in seconds, in the 
Duration field, and then click Done
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You can also make adjustments to a transition by opening the Precision Editor.  Select 
the Precision Editor by clicking on the wheel icon in the transition in the Timeline.

Sharing or Exporting Your Video

You can export your video to share in different places.

1. Click on Share
2. Click on where you want to share your video (iDVD, YouTube, Facebook, etc.)

a. Select the screen size and file options that you want (biggest is best)
b. You will need to input your account details as required
c. iDVD will automatically open that program
d. For Denver Open Media, use the Movie option, which is also a good way to make 

a complete copy of your program

Practice!

Building your editing skills takes time.  Practice, and don’t be afraid to experiment.  
There are also a lot of good resources out there if you have questions.  Apple has a great users 
forum, and YouTube has plenty of how-to videos.

Script for Classroom Exercise

In the field production workshop, we focus on ease and affordability in professional 
quality video production. The field production workshop takes students into the process of 
cinematography, lighting and audio. With a focus on the manual controls available through the 
larger 3-chip cameras, such as those by Sony or Canon, this class is intended for students who 
either already have a basic understanding of the fundamentals, or for folks who have never 
touched a camera before. Learn how to use shutter speed, iris, focus and audio like a pro in 
order to get the highest quality video possible. Upon completion of this class, Denver Open 
Media members will be certified to use the advanced digital video cameras, lighting and audio 
equipment available through Denver Open Media free of charge, to make your own shows and 
films for our channels.
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