
Intermediate Editing with Adobe Premiere Pro
Instructor: John Aden

Goals of the Course

● Show advanced video editing techniques with Premiere Pro
● Show how other Adobe applications (i.e., Photoshop and After Effects) can be used with 

Premiere
● Show additional sharing options using Media Encoder

A Quick Review of Basic Editing with Adobe Premiere Pro (refer to the curriculum 
for the Editing with Adobe Premiere Pro class)

● File management
● Creating a new project
● Scratch disks
● Review of interface
● Importing footage
● Organizing footage in bins and color coding
● Creating a sequence
● Selecting and bring footage to the timeline
● Basic editing

A Deeper Look into the Toolbar

Use of different tools in the Toolbar can make for more efficient editing.

Selecting Tracks

Use the Track Select Tool (A) to select all clips in a particular track.  Notice that it will select the 
clips to the right of where you click on the Timeline.  With the same tool selected, you can shift-
click to select clips on all tracks to the right of where you click on the Timeline.

Ripple Edit Tool

This tool is helpful for shortening clips and moving the rest of the clips in the timeline along with 
it so as there is no gap left after the edit is done.

1. Select the Ripple Edit Tool (B) in the Toolbar
2. Hover over the end/start of the clip that you want to shorten
3. Notice how the icon turns yellow instead of red
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4. Click and drag to shorten the clip as needed

Rolling Edit Tool

This tool is helpful for keeping the same length of the show while shortening the length of one 
clip and increasing the length of another adjacent clip.

1. Select the Rolling Edit Tool (N) in the Toolbar
2. Click and drag the edit point left or right to make the desired adjustment

Rate Stretch Tool

Use this tool to change the rate of a clip (i.e., slow or fast motion).

Slip Tool

Simultaneously changes the in and out points of a clip without changing the length of the clip.  
This tool is helpful for changing the action seen within a clip when the duration of the clip is 
correct.

1. Select the Slip Tool (Y) in the Toolbar
2. Click and drag left and right over the clip to change the in and out points (which you can 

see in the Program Monitor)

Slide Tool

This tool is helpful for moving a clip without changing its length or leaving a gap.

1. Select the Slide Tool (U) in the Toolbar
2. Click and drag left or right to move the clip to the desired location

Insert and Overwrite

These tools can be used to either insert or overwrite a clip, with its selected in and out points, 
directly into the Timeline where the playhead is parked.  The insert edit will move subsequent 
clips farther down the Timeline, while the overwrite edit will overwrite any clips in the Timeline.

Making Subclips

If you have shorter clips that you want to mark and pull out of a long clip, you can make subclips

1. Double-click the long clip in the Project window
2. In the Source window, set the in and out points of the new shorter clip you wish to create
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3. Select Clip-Make Subclip
4. The subclip is now available in the Project window

Duplicating Sequences for Version Control

If you are not sure about the changes you are about to make to a sequence, you can maintain 
version control by duplicating the sequence and working in the new copy of that sequence.  
That way, you will always have the previous version of your sequence to fall back on.

1. Right-click on the sequence and click Duplicate; a copy of that sequence will appear in 
the Project window

2. Click twice on the sequence name to rename it
3. Give it an appropriate name (Sequence-DATE, Sequence V2, etc.)

Keyframing

Keyframes can be used to set the start and end points of a change in a clip.  These changes 
can be for the properties of audio or video or effects.

Setting Keyframes in the Timeline

1. Expand a clip’s audio track in the Timeline by clicking on the arrow next to Audio 1
2. Select the Pen Tool (P)
3. Hover the pen over the yellow line on the clip’s audio track; you will notice that a plus 

symbol appears
4. Place keyframes on the line by clicking
5. Click and drag to move the keyframes to create fades

Keyframes can also be applied in the Timeline to the yellow Opacity line in the video track of a 
clip.

Setting Keyframes in the Effects Control Panel

1. Move the playhead to the beginning of a clip
2. Double-click on a clip in the Timeline
3. In the Source window, switch to the Effects Control panel
4. Click on the arrow next in the Motion row
5. Click on the stopwatch icon on the Position scale; this sets your starting keyframe
6. Move the playhead forward along the length of the clip, either in the Timeline or the 

Source window
7. Change the position of the clip by dragging along the yellow numbers (X and Y 

coordinates) in the Position row; notice that an ending keyframe has also been created
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8. Play the clip to see the motion you have created

Basic Color Correction

Fixing the Exposure of a Shot

1. Select the Fast Color Corrector in the Effects tab of the Project window
2. Drag the Fast Color Corrector on top of the clip you want to adjust
3. Place the playhead in the Timeline over the clip you want to adjust (so you can see your 

adjustments in the Program Monitor)
4. Double-click on the clip to open it in the Source window
5. Click on the Effects Control tab in the Source window
6. On the Input Levels slider, adjust the black, mids, and white sliders to bring up or down 

the exposure
7. Adjust the Saturation level as needed
8. Toggle the fx button near the Fast Color Corrector video effect in the Source viewer to 

see a before and after of your changes

Fixing Incorrect White Balance

1. Select the Fast Color Corrector in the Effects tab of the Project window
2. Drag the Fast Color Corrector on top of the clip you want to adjust
3. Place the playhead in the Timeline over the clip you want to adjust (so you can see your 

adjustments in the Program Monitor)
4. Double-click on the clip to open it in the Source window
5. Click on the Effects Control tab in the Source window
6. Click and drag on the circle in the middle of the wheel to make adjustments
7. The bar can also be moved to changed the intensity of the effect
8. Toggle the fx button near the Fast Color Corrector video effect in the Source viewer to 

see a before and after of your changes

Using the Three-Way Corrector

The Three-Way Corrector can be used to make color balance changes separately to the whites, 
mids, or blacks.  For instance, you can make a bluer sky by adjusting the color balance of the 
whites and not affect the color balance of the rest of the shot.

RGB Color Corrector

Make color corrections by changing the values of the reds, blues and greens of a clip.  Adjust 
the Pedestal, Gain and Gamma numbers for the Blues, Greens and Reds.
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Green Screen

Use the Ultra Key effect to key your green screen background.

1. Place the clip with the green screen footage in the Timeline (on Video track 2)
2. Place the background footage or image below the other clip in the Timeline (on Video 

track 1)
3. Make sure the playhead is parked above both clips in the Timeline
4. In the Effects tab in the Project window, find the Ultra Key effect (under Video Effects-

Keying)
5. Click and drag the Ultra Key effect and drop it on the clip with the green screen footage 

in the Timeline
6. Double-click on the clip with the green screen footage
7. In the Source window, go to the Effect Controls tab
8. Under the Ultra Key, click on the eyedropper tool
9. With the eyedropper tool, select a green portion of the footage in the Program window
10. Clean up the matte by making adjustments

a. In Output, switch to Alpha Channel - you will want a clean black background and 
a clean white background

b. Make adjustments in the Matte Generation first, starting with Pedestal
c. Add contrast to the matte by bringing up the Contrast in Matte Cleanup
d. When done, switch back to the Composite mode in Output

Warp Stabilizer

Have shaky footage?  Try the Warp Stabilizer.

1. Find the Warp Stabilizer effect in the Effects tab in the Project window under Video 
Effects-Distort

2. Drag the effect on top of the clip you want to fix in the Timeline

Using Photoshop to Create a Bug for Your Video

A bug is a logo that you typically see on the lower right corner of a video, often used by 
networks for identification.

1. Select File-New-Photoshop File
2. Verify the Video Settings and click OK
3. Give the file and name and click Save
4. Photoshop will open
5. Select File-Place, select the file for the logo you want to use, and click Place
6. Size the logo appropriately (center the logo on the screen and make it large) and hit 

Return
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7. Right-click on the logo’s layer in Photoshop and click Rasterize Layer
8. Select the Magic Eraser Tool
9. Click to erase any unwanted background elements of your logo
10. Select File-Save
11. Return to Premiere Pro
12. Drag the Photoshop file (.psd) from the Project window into the Timeline on a video track 

above a clip where you want the bug to appear
13. Make the clip of the bug as long as desired by stretching its length on the Timeline
14. Make sure the playhead is parked above the bug in the Timeline
15. Double-click on the bug clip in the Timeline
16. Select the Effects Control tab in the Source window
17. Position and size the bug by dragging along the yellow numbers (Position and Scale) in 

the Motion section of the Video Effects

You can also add some transparency to your bug.

1. Return to Photoshop
2. Double-click on the logo’s layer to open the Layer Style panel
3. Check the Bevel & Emboss style
4. Select the Bevel & Emboss style to open its options in the panel
5. Slide the Depth slider to around 500
6. Slide the Size slider to around 10
7. Click OK
8. Above the logo’s layer, drag the Fill slider to 0%
9. Select File-Save
10. Return to Photoshop to see the updated bug on your video

Using Photoshop to Create a Lower Third

1. Click File-New-Photoshop File
2. Confirm the settings match your sequence settings and click OK
3. Give the Photoshop file a name and save in your Media folder
4. Photoshop opens with a blank transparent screen
5. Click on the Horizontal Type Tool (T)
6. Click in the work area where you want to start typing
7. Type text and change the font, size, and color as desired
8. Click on the Move Tool (V)
9. Position the text as desired; keep all text inside the title safe area (innermost turquoise 

lines)
10. Click on the Create a new layer button in the bottom of the Layers panel to the right of 

the workspace
11. Click on the Rectangle Tool
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12. Draw a rectangle in the workspace
13. Change the Fill and Stroke color as desired
14. Reposition the rectangle with the Move Tool (V)
15. To resize the rectangle, type command-T; press return when finished
16. Create a new layer in the Layers panel
17. Click File-Place, select an image to include in the lower third, and click Place
18. Resize and position the image on the rectangle as desired and press return
19. Rearrange the layers in the Layer Panel so the text and image layer are above the 

rectangle
20. Click File-Save
21. Return to Premiere
22. Drag the .psd file from the Project window into the timeline on the video track above the 

clip you wish to add the title to
23. Return to Photoshop
24. Double-click on the text layer and add a drop shadow
25. Double-click on the rectangle layer and bring down the opacity
26. Click File-Save
27. Return to Premiere; notice that your updates are automatically reflected in the Timeline

Adding Some Flash to Your Lower Third with After Effects

1. In Premiere Pro, select File-Adobe Dynamic Link-New After Effects Composition
2. Select File-Import-File
3. Navigate and select the Photoshop (.psd) file of your lower third and click Open
4. For Import Kind, select Composition, and Layer Options should be selected to Editable 

Layer Styles, and click OK
5. Drag and drop the composition with the filename of your lower third into the Composition 

window in the bottom left of the After Effects screen
6. In the Effects & Presets tab on the right side of the screen, find the CC Light Sweep 

effect in the Generate category
7. Drag and drop the CC Light Sweep effect on top of your lower third composition in the 

Composition window
8. Click on the arrow to the left of the composition name to expand the settings; you should 

see the CC Light Sweep effect
9. Drag on the yellow number on the left (X coordinate) of the Center to change the 

location of the light sweep
10. Move the light sweep off the left side of the screen
11. Move the playhead to second 1 in the timeline (this will give the title time to fade up in 

Premiere before the effect plays)
12. Click the stopwatch icon next to Center; a keyframe is created in the timeline, and this 

will be the starting point for your animation
13. Move the playhead forward to second 2 in the timeline
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14. Drag on the X coordinate of the Center to off the right side of the screen; notice that a 
second keyframe is created in the timeline

15. Click spacebar to play the effect
16. Select Composition-Composition Settings
17. Change the Duration of the composition to 7 or so seconds and click OK
18. Select File-Save
19. Switch back to Premiere
20. Drag the linked After Effects composition in the Project panel into the Timeline

Rolling Credits

1. Select Title-New Title-Default Roll
2. Keep the same Video Settings and press OK
3. Click in the title screen, select size and font, and enter text
4. Press Center (top of box) and center it horizontally by clicking the Horizontal Center 

button (left side of box)
5. Click on the Roll/Crawl Options button in the top left of the title box
6. Check the Start Off Screen and End Off Screen bottoms in the Roll/Crawl Options box 

and click OK
7. Type your credits
8. Drag the title into the Timeline
9. Use the Rate Stretch Tool to make the titles roll faster or slower

Multi-Camera Editing

1. Park playhead on clap point (you can also align to the audio waveform by selecting that 
in the dropdown menu on the top right of the Source window)

2. Mark in-point on clip
3. Repeat for each camera angle
4. Select the clips in the Project window (be sure to select the camera with the primary 

audio first!)
5. Right-click and select Create Multi-Camera Source Sequence
6. In the Create Multi-Camera Source Sequence box, name the sequence, select the In 

Points button, and click OK
7. Double-click the new multicam sequence to open it in the Source window
8. Drag the multicam sequence into a new sequence on the timeline
9. Select Window-Multi-Camera Monitor
10. Click on the Play button
11. Switch between the different angles by clicking on them in the monitor or using the 

number buttons (1, 2, 3, etc.)

8



12. Click the Stop button
13. Notice the cuts made are automatically represented in the Timeline

Basic DVD Creation with Encore

1. In Premiere Pro, select File-Adobe Dynamic Link-Send to Encore
2. Encore will open up with a New Project box
3. Select Blu-ray or DVD, give the DVD a name, select the file location, and click OK
4. Your movie should appear in the Encore timeline
5. You can add remote chapter markers (the viewer can skip forward to these points) by 

moving the playhead and clicking on the Add Chapter button to the left of the timeline
6. Click on the Flowchart tab in the center top window; make sure the DVD icon is linked to 

your clip
7. Click on the clip
8. Go to the Properties panel in the top right window and change End Action to Stop
9. Click on the DVD icon in the top middle window
10. Go to the Properties panel and drag the curly icon for the Title Button and link it to your 

movie’s icon (not the DVD icon) in the Flowchart tab in the center top window
11. Go to the Build tab in the top left window and give the DVD a name under Settings
12. Click Check Project
13. In the Check Project box click Start; you should see the message “No items found,” 

meaning the project is ready to burn
14. In the Build tab, change Format to DVD, Output to DVD Disc, and click Build
15. Insert a blank DVD and click OK to begin burning

Exporting Your Video for Denver Open Media

1. Click File > Export > Media...
2. Make sure the Source Range is set to Entire Sequence (or that you have properly 

selected the portion of your program that you want to export)
3. Set Format to QuickTime
4. Set Preset to HD 1080i 29.97, H.264, AAC 48kHz (if your program is in HD or high 

definition)
5. Set Preset to NTSC, H.264, AAC 48kHz (if your program is in SD or standard definition)
6. Click on Output Name to name your file and choose where to save it
7. Make sure the Export Video and Export Audio boxes are checked
8. Click the Export button

Exporting Your Video for Other Destinations

1. Click File > Export > Media...
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2. Make sure the Source Range is set to Entire Sequence (or that you have properly 
selected the portion of your program that you want to export)

3. Click on Output Name to name your file and choose where to save it
4. Click the Queue button to open Adobe Media Encoder
5. Select one of the System Presets (YouTube, Apple Devices, DVD, etc.) and drag it to 

the Queue on the left
6. Click on the green arrow to being the export
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